• W
    wad1m

    Just realized i had the .hxproj project file in the build folder all this time.
    For some reason i was looking up for similar build as Kode Studio F1->init option

    Now i did figure out how to execute this command in any empty folder like so:
    C:\Users\Ultimate\Desktop\New folder> node C:\HaxeToolkit\haxe\lib\kha\git\make html5

    I understand this script requires the configuration files to be present since I'm getting this error:
    Neither Kha directory nor project file (khafile.js) found

    So basically I'm looking for something like a HaxeDevelop template for kha , or some method to see the .hx files in the build project so i could run & debug straight from HaxeDevelop.

    If that's not possible right now, i have no technical troubles in running and debugging from KodeStudio ( It's just a bit buggy with the auto-completion and very slow on my system )

    posted in Kode read more
  • W
    wad1m

    sorry i might be missing something here.
    this is what i have done:

    • created an empty folder in desktop
    • ran the script

    this is what i get:

    C:\Users\Ultimate\Desktop\New folder> node Kha/make flash
    module.js:471
    throw err;
    ^
    Error: Cannot find module 'C:\Users\Ultimate\Desktop\New folder\Kha\make'
    at Function.Module._resolveFilename (module.js:469:15)
    at Function.Module._load (module.js:417:25)
    at Module.runMain (module.js:604:10)
    at run (bootstrap_node.js:390:7)
    at startup (bootstrap_node.js:150:9)
    at bootstrap_node.js:505:3
    C:\Users\Ultimate\Desktop\New folder>

    posted in Kode read more
  • W
    wad1m

    Yes i have tried that, but i don't seem to have the khamake in my cmd path. could you provide an example ?

    posted in Kode read more
  • W
    wad1m

    Not sure if this problem accrues only in my system or what, but when i empty space when there is no parameters in the function the syntax highlighter seems to break down.

    GIF IMAGE :
    https://drive.google.com/file/d/0BxEU9U4a16P_WmF0dWRnRGZLbFU/view

    (edit): "vat" syntax error doesn't cause that , i changed it to "var signals..." but the problem still remains

    posted in Kode read more
  • W
    wad1m

    Is there any way to run kha with code completion in haxedevelop ?

    posted in Kode read more

Looks like your connection to Kode Forum was lost, please wait while we try to reconnect.